Leitfaden zur Fehlerbehebung bei Arduino Punktschweißgeräten

Diese Anleitung soll Ihnen bei den häufigsten Problemen helfen, die bei der Verwendung des DIY Arduino Battery Spot Welder auftreten können

Schweißpunkte nicht stark genug

Stromversorgung:

Die Stärke der Schweißpunkte hängt stark von der Stromversorgung des Punktschweißers ab. Ihre Autobatterie oder Ihr Lipo sollte 400 – 600A Strom liefern können.

Um die besten Ergebnisse zu erzielen, wird empfohlen, eine Autobatterie mit 600 A (CCA) oder einen Lipo zu verwenden, der so viel Strom liefern kann. (z.B. 3s 5000mAh 60-130C)

Nickelstreifen:

Je nachdem, welche Nickeldicke Sie verwenden, müssen Sie die richtige Stromquelle auswählen. Das Schweißen von 0,1 mm bis 0,15 mm Nickel funktioniert schon mit einem Strom von 400 A. Aber um gute Schweißpunkte auf 0,2 mm oder noch dickerem Material zu bekommen, benötigen Sie etwa 600 A Strom.

Anpressdruck:

Wichtig ist auch, wie stark Sie die Schweißspitzen beim Schweißen gegen das Nickel drücken. Sie müssen etwas Druck ausüben (ca. 1 kg). Aber drücken Sie nicht zu stark, da dies die Schweißpunkt Qualität wieder verringert.

Indem Sie vor dem Schweißen einmal kräftig drücken und dann die Punktschweißkabel nur leicht andrücken, sollten Sie in der Lage sein, gute Verbindungen zu erzielen.

Display bleibt schwarz

In den meisten Fällen, wenn das Oled-Display schwarz bleibt, ist dies ein Problem des Arduino Nano. Das Display schaltet sich nur ein, wenn es ein gültiges Signal erhält.

Versuchen Sie zunächst, die Software erneut auf den Arduino Nano hochzuladen. Siehe das Tutorial

Hilft dies nicht, könnte es sich auch um ein Kontaktproblem der Stiftleiste des Displays handeln. Entfernen Sie die 2 Schrauben, mit denen das Display befestigt ist, und ziehen Sie es aus der Steckverbindung ab. Stecken Sie es dann wieder ein.

Sollten Sie einen Ersatz-Arduino verfügbar haben (es muss kein Arduino Nano sein), können Sie die Punktschweißsoftware darauf hochladen und das Display daran anschließen, um zu prüfen, ob das Display an sich funktioniert. Auf diese Weise steht nun fest ob das Display selbst oder der Arduino Nano defekt ist.

V3 - Schweißpuls wird nicht aktiviert oder es funkt sofort

Einstellung des Schweißmodus

Prüfen Sie zuerst, ob Sie das Schweißgerät auf den richtigen Schweißmodus eingestellt haben. Im manuellen Modus wird der Schweißimpuls nicht automatisch aktiviert. Nur wenn der Fußschalter gedrückt wird. Wenn es sich im Auto-Modus befindet, können Sie den Schweißimpuls nicht kontrolliert durch Drücken des Fußschalters aktivieren. Er wird automatisch ausgelöst, wenn beide Schweißspitzen das Nickelband berühren.

Hardwareproblem

Funktioniert der Welder nur im Auto-Modus, aber nicht im manuellen Modus, könnte der Fußschalter defekt oder falsch angeschlossen sein. Sehen Sie in der Montageanleitung nach, wie der Fußschalter angeschlossen werden muss.

Wenn es keinen Impuls auslöst oder sofort schweißt (Kurzschluss), liegt höchstwahrscheinlich ein Hardwaredefekt am Schweißgerät vor. Um herauszufinden, um welches Teil es sich handelt, benötigen Sie für einige Messungen ein Multimeter.

Dann könnten Sie Folgendes tun:

Überprüfen Sie die Spannung an Pin D5 des Arduino Nano. Diese sollte 0V sein und nur während einer Impulsaktivierung auf 5V steigen.
Wenn es immer 5 V sind, ist das ein Indikator dafür, dass der Arduino Nano defekt ist.

Als nächstes überprüfen Sie die Spannung an der 8-poligen Stiftleiste, die die Mosfet-Platine und die Arduino-Platine verbindet.
Sie sollte ungefähr 0V sein. Wenn es immer 12 V sind, während an Pin D5 des Arduino Nano 0 V anliegen, ist dies ein Indikator dafür, dass der Mosfet-Treiber MCP1407 defekt ist.

Eine andere Sache, die ausgefallen sein könnte, ist eine der 4 großen Schutzdioden auf der Unterseite der Mosfet-Platine.
Deren Beschädigung ist in der Regel durch Risse in der Diode oder schwarze Brandflecken um die ausgefallene Diode sichtbar.
Wenn diese kaputt gehen, neigen sie zu einem Kurzschluss.

Sie können auch den Widerstand zwischen den 2 Aluminiumteilen messen (bei ausgeschaltetem Schweißgerät). Dieser sollte dann etwa 1k Ohm oder bei älteren Schweißern 150 Ohm betragen.
Wenn er nahe Null ist, wird das Problem höchstwahrscheinlich durch eine defekte Schutzdiode verursacht.

V4 - Schweißpuls wird nicht aktiviert oder es funkt sofort

Einstellung des Schweißmodus

Prüfen Sie zuerst, ob Sie das Schweißgerät auf den richtigen Schweißmodus eingestellt haben. Im manuellen Modus wird der Schweißimpuls nicht automatisch aktiviert. Nur wenn der Fußschalter gedrückt wird. Wenn er sich im Auto-Modus befindet, können Sie den Schweißimpuls nicht kontrolliert durch Drücken des Fußschalters aktivieren. Er wird automatisch ausgelöst, wenn beide Schweißspitzen das Nickelband berühren.

Hardwareproblem

Funktioniert er nur im Auto-Modus, aber nicht im manuellen Modus, könnte der Fußschalter defekt oder falsch angeschlossen sein. Sehen Sie in der Montageanleitung nach, wie der Fußschalter angeschlossen werden muss.

Wenn er keinen Impuls auslöst oder sofort schweißt (Kurzschluss), liegt höchstwahrscheinlich ein Hardwaredefekt am Schweißgerät vor. Um herauszufinden, um welches Teil es sich handelt, benötigen Sie für einige Messungen ein Multimeter.

Dann könnten Sie Folgendes tun:

Bitte werfen Sie einen Blick auf die Mosfet-Platine und prüfen Sie, ob die 6 Mosfets oder die 3 Dioden auf der Unterseite der Platine sichtbare Schäden aufweisen. Das können z.B. Risse im Komponentengehäuse oder Brandflecken an und um die Komponenten sein.

Wenn das gut aussieht (keine Beschädigungen) können Sie den Widerstand zwischen den beiden Aluminiumteilen messen. Dazu muss das Mosfet-Board mit der oberen Hälfte des Welders zusammengesteckt sein. Es sollten ungefähr 1000 Ohm sein. Wenn es nur bei ausgeschaltetem Schweißgerät 1000Ohm, aber bei eingeschaltetem Schweißgerät 0 Ohm sind, ist es ein Problem der Steuerelektronik. (Arduino Nano oder Mosfet-Treiberchip)

Überprüfen Sie die Spannung an Pin D5 des Arduino Nano. Diese sollte 0V sein und nur während einer Impulsaktivierung auf 5V steigen. Wenn es immer 5 V oder noch höher sind, ist dies ein Indikator dafür, dass der Arduino Nano defekt ist.

Als nächstes überprüfen Sie die Spannung an der 6-Pin Stiftleiste, die die Mosfet-Platine und die Arduino-Platine verbindet. Es sollten ungefähr 0V anliegen. Wenn es immer 12 V sind, während an Pin D5 des Arduino Nano 0 V anliegen, ist dies ein Indikator dafür, dass der Mosfet-Treiber MCP1407 defekt ist.

Schweißspitzen abgenutzt

Nach vielen hundert Schweißpunkten verschleißen die Schweißspitzen. Sie können sie ganz einfach „auffrischen“, indem Sie sie mit Schleifpapier oder einer Feile etwas nachschleifen. Für beste Schweißergebnisse sollten die Spitzen immer sauber aussehen. Wenn zu viel „verbranntes Material“ darauf ist, kann dies zu einem schlechten elektrischen Kontakt zum Nickelband führen.

Wenn Sie die Spitzen so stark beschädigt haben, dass sie nicht mehr geschliffen werden können, müssen Sie sie ersetzen oder einen neuen Schweißkabelsatz besorgen. Es ist ein Tutorial zum Wechseln der Schweißspitzen verfügbar.